You are here: > ESRI Forums > arcgis server forums > Thread Replies

ArcGIS Server Forums

ArcGIS Server .Net: Using the Web Mapping Application forum

ArcGIS Server Manager - Cannot connect on l...   david wright Jun 03, 2007
Re: ArcGIS Server Manager - Cannot connect...   Tom Wang Jun 03, 2007
Re: ArcGIS Server Manager - Cannot connect...   John Tyce Jun 28, 2007
Re: ArcGIS Server Manager - Cannot connect...   david wright Jun 28, 2007
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject ArcGIS Server Manager - Cannot connect on localhost 
Author david wright 
Date Jun 03, 2007 
Message I've published some map services and can connect to them in ArcCatalog on the server itself, but not on remote machine. I'm trying to connect to the remote map service from a client PC using ArcCatalog with: "http://server.domain.org/ArcGIS/USA/MapServer" I'm assuming I can't connect remotely because I have not run the ArcGIS Server Manager yet. Rather, I "Manage GIS Services" in ArcCatalog on the server. I have not been able to connect to the ArcGIS Server Manager yet, even on the localhost. I'm using: http://localhost/ArcGIS/Manager/default.aspx and I get the following message every time:

XML Parsing Error: no element found
Location: http://localhost/ArcGIS/Manager/default.aspx
Line Number 1, Column 1:

Anyone know how to help?

Thanks much

Dave Wright 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: ArcGIS Server Manager - Cannot connect on localhost 
Author Tom Wang 
Date Jun 03, 2007 
Message It songs you massing Web Applications Post Install for ArcGIS Server Manager. 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: ArcGIS Server Manager - Cannot connect on localhost 
Author John Tyce 
Date Jun 28, 2007 
Message It sounds like you are using FireFox. If so, the XML Parsing error is happening because the server manager is returning a blank page. I am having the same problem. If you try to navigate to the page using IE, you will get a blank page with no error. If you look in the Windows Event Viewer you will see an error there. I don't know how to fix your problem, but I just wanted to point you away from the XML parsing error if you are using FireFox. 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: ArcGIS Server Manager - Cannot connect on localhost 
Author david wright 
Date Jun 28, 2007 
Message Thanks John. I want to note that my issue is now resolved. Thanks to the great support at ESRI, we were able to identify my problem. I had some Web applicaitons (.NET apps) on my E drive. When I installed ArcGIS Server the default location for IIS was "C:\Inetpub\wwwroot" and it was causing a conflict. There is an article that helped ( http://support.esri.com/index.cfm?fa=knowledgebase.techarticles.articleShow&d=32546 ). Essentially, you have to change a registry key before installing ArcGIS Server. Here are the steps that led to success:

1. Uninstall ArcGIS Server

2. Delete the accounts associated with the ArcGIS installation (ArcGISSOC, ArcGISSOM) and the groups (agsadmin, agsusers)

3. In IIS, make sure the ArcGIS folder as well as the virtual directories (Manager, etc) in your Web site are all deleted

4. In Windows Explorer make sure that the arcgisserver output folder and contens are deleted (for me it was E:\arcgisserver\arcgiscache, E:\arcgisserver\arcgisjobs, and E:\arcgisserver\arcgisoutput
I also deleted E:\arcgisserver)

5. Edit the registry key from the above mentioned article from default (record the default setting somewhere so you can change it back) to the location of your web app root. Mine was on the E: drive, example E:\wwwroot\

6. Reinstall ArcGIS Server

7. Run the GIS Server post install

it works !! now I can connect ot manager on local host as well as from remote PC's

8. Run the service packs for your ArcGIS server version

9. You'll then have to run the GIS Server post install again

10. Lastly, change your registry key back to the default setting that you recorded (usually "C:\Inetpub\wwwroot").

-Dave