You are here: > ESRI Forums > arcgis server forums > Thread Replies

ArcGIS Server Forums

ArcGIS Server Java: Developing applications forum

java.lang.NoClassDefFoundError: edu/emory/m...   Jeff Wang Oct 12, 2007
Re: java.lang.NoClassDefFoundError: edu/emo...   James Schek Oct 13, 2007
Re: java.lang.NoClassDefFoundError: edu/emo...   Jeff Wang Oct 15, 2007
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject java.lang.NoClassDefFoundError: edu/emory/mathcs/backport/java/util/concurrent/Future 
Author Jeff Wang 
Date Oct 12, 2007 
Message Created a Web Application in AGS Manager, then imported the war in Eclipse, and got the above error when trying to run in tomcat5.5. If create a project from scratch in Eclipse. The project will run.

Any ideas?

TIA,

Jeff 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: java.lang.NoClassDefFoundError: edu/emory/mathcs/backport/java/util/concurrent/Future 
Author James Schek 
Date Oct 13, 2007 
Message Sounds like you're missing the Backport Concurrent Util jar. If I reall correctly, it's included with AXIS2 in eclipse. Have you compared the classpath list on your eclipse-born project vs your ags-born project? 
  James L. Schek
Software Developer
Lawrence Livermore National Laboratory

"Computer Science: A study akin to numerology and astrology, but lacking the precision of the former and the success of the latter." --Stan Kelly-Bootle
 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: java.lang.NoClassDefFoundError: edu/emory/mathcs/backport/java/util/concurrent/Future 
Author Jeff Wang 
Date Oct 15, 2007 
Message Your are right on the target James. The imported WAR didn't include the backport-util-concurrent.jar.

Thanks,

Jeff