You are here: > ESRI Forums > arcgis server forums > Thread Replies

ArcGIS Server Forums

ArcGIS Server Java: Developing applications forum

9.3: XML parser error on WMS   Joan Fang Sep 30, 2008
Re: 9.3: XML parser error on WMS   Joan Fang Oct 17, 2008
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject 9.3: XML parser error on WMS 
Author Joan Fang 
Date Sep 30, 2008 
Message I am using ArcGIS 9.3, and I tried to display a WMS resource. and I received this error:


Sep 30, 2008 11:26:27 AM com.esri.internal.wms.client.impl.RequestHandlerImpl parseCapabilitiesResponse
SEVERE: java.lang.UnsupportedOperationException: This parser does not support specification "null" version "null"
Sep 30, 2008 11:26:27 AM com.esri.adf.web.data.a run
SEVERE: Unable to initialize resource 'wms0'. This resource will be removed
com.esri.adf.web.wms.ADFWMSException: Unable to initialize WMS Map Resource : http://www.****


Does anybody have a clue, where is the problems is?

Thanks 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: 9.3: XML parser error on WMS 
Author Joan Fang 
Date Oct 17, 2008 
Message I think very few people use Jdeveloper as the ArcGIS IDE.
The problem I got is from using Jdeveloper. In Jdeveloper there is a jar named xmlparser2.jar. It includes javax.xml.parser..., which is conflicting with ESRI's class. You need to delete it to get ride of this error.