You are here: > ESRI Forums > arcgis server forums > Thread Replies

ArcGIS Server Forums

ArcGIS Server ArcSDE: Informix forum

ArcSDE service won't start   Rob Livermore Oct 16, 2008
Re: ArcSDE service won't start   Diwakar Kanchi Oct 16, 2008
Re: ArcSDE service won't start   Rob Livermore Oct 17, 2008
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject ArcSDE service won't start 
Author Rob Livermore 
Date Oct 16, 2008 
Message ArcSDE 9.2 sp5,sp6
ArcSDE 9.3
Oracle 10.2.0.4
AIX 5.3 ML07

ArcSDE 9.2 installed, repository successfully created, sde won't start, no giomgr or sde log files generated. Only error is:
Can not start ArcSDE, check for zombie processes.

No iomgr/giomgr in /tmp. SDE user can write to temp location. No path errors, oracle is up, sdeinstance variable set in .profile, along with other prerequisites. Root user cannot start process.
I have dropped/recreated SDE schemas in oracle.
I have two separate sde users on server, one for 9.2, one for 9.3, all installs/sdesetup repositories created successfully
Same error occurs on both.
Any one experience this before, any idea on what it may be, network/dns issues?

Below are the results of a truss on sdemon -o start

Cheers

Rob 
 
sdetest1@ee0106tst:/home/sdetest1>truss -f -t open,statx sdemon -o start
835638: open("/unix", O_RDONLY|O_LARGEFILE)             = 3
835638: open("/apps/db3/esri/sdeexe92_test/etc/services.sde", O_RDONLY) = 3
Please enter ArcSDE DBA password:
835638: open("/etc/resolv.conf", O_RDONLY)              = 3
835638: open("/etc/netsvc.conf", O_RDONLY)              = 3
835638: open("/etc/hesiod.conf", O_RDONLY)              Err#2  ENOENT
835638: open("/etc/irs.conf", O_RDONLY)                 Err#2  ENOENT
835638: open("/etc/hosts", O_RDONLY)                    = 3
835638: open("/etc/hosts", O_RDONLY)                    = 3
835638: open("/etc/services", O_RDONLY)                 = 3
835638: open("/etc/hosts", O_RDONLY)                    = 3
835638: open("/etc/hosts", O_RDONLY)                    = 3
835638: open("/etc/services", O_RDONLY)                 = 3
835638:                                 (sleeping...)
835638:                                 (sleeping...)
835638:                                 (sleeping...)
Can not start ArcSDE, Check for zombie process.
 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: ArcSDE service won't start 
Author Diwakar Kanchi 
Date Oct 16, 2008 
Message Check the below link, may be useful for your problem:

http://forums.esri.com/Thread.asp?c=158&f=2290&t=260364
 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: ArcSDE service won't start 
Author Rob Livermore 
Date Oct 17, 2008 
Message Diwakar,

Thanks for the link, unfortunately sdeservice is not used on unix.

I looked at the server and instance variables in my path and they are fine.

Sorry for posting this in the Informix forum, meant to post in the Oracle forum.

Cheers

Rob