You are here: > ESRI Forums > arcsde (9.1 and older) users online discussion forum > Thread Replies

ArcSDE (9.1 and older) Users Online Discussion Forum

ArcSDE: Microsoft SQL Server forum

Entry for SDE Instance not found in service...   Muhammad Abdul Hadi Muhammad Abdul Majid Oct 31, 2004
Re: Entry for SDE Instance not found in ser...   mody buchbinder Oct 31, 2004
Re: Entry for SDE Instance not found in ser...   Muhammad Abdul Hadi Muhammad Abdul Majid Nov 01, 2004
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Entry for SDE Instance not found in services file 
Author Muhammad Abdul Hadi Muhammad Abdul Majid 
Date Oct 31, 2004 
Message Server Configuration
OS: Windows Server 2003 Enterprise Edition
DBMS: Microsoft SQL Server 2000 Enterprise Edition SP3
ArcSDE Version: 9.0

Clinet Configuration
OS: Windows XP Professional SP2
ArcGIS Desktop Version: 9.0
Lisence: Arc View(Floating)

Installation Configuration:
Nothing was changed from the default configurations(Except passwords).

Problem: When trying to connect to database from Client following error message is displayed

Failed to connect to database
Entry for SDE Instance not found in services file

Supporting hints:
1. Both Client and server can ping each other.
2. Clent can connect to database through OLE DB Connection.
3. Server can itslef connect to the service(esri_sde) and view spatial information.

Steps Already taken to solve the problem:

1. c:\windows\system32\drivers\etc\services file is opened in notepad and confirmed for following entry:
esri_sde 5151/tcp #ArcSDE
Further more we surely to added one blank line after this entry.
2. Restarted both Server and Client.

Note: All connection attempts are done through Arc Catalog 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Entry for SDE Instance not found in services file 
Author mody buchbinder 
Date Oct 31, 2004 
Message Hey mhadi

Instead of writing esri_sde try to write 5151 as the instance in ArcCatalog.
I would delete and rewrite the line in the service file and make sure there is no other similar lines.

Have Fun
Mody 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Entry for SDE Instance not found in services file 
Author Muhammad Abdul Hadi Muhammad Abdul Majid 
Date Nov 01, 2004 
Message Hi,
Thanks for replying
your solution(write 5151 instead of esri_sde) hits the target
Thank you
mhadi