You are here: > ESRI Forums > arcgis desktop discussion forums > Thread Replies

ArcGIS Desktop Discussion Forums

ArcGIS Desktop - Installation, Releases, Licensing forum

“FLEXnet Licensing Error -15,10. System Er...   S R Nov 21, 2008
Re: “FLEXnet Licensing Error -15,10. Syste...   Oren Gabay Nov 23, 2008
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject “FLEXnet Licensing Error -15,10. System Error:10060: “WinSock: Connection Timed Out” 
Author S R 
Date Nov 21, 2008 
Message Hi Folks,

I have installed ArcGIS Desktop 9.3 in my PC (Win XP SP2) and pointing its license to the another machine where license manager installed with required license. The two machines are in different network.

I could able to ping the license manager machine and getting replies. I'm even doing a remote desktop connection and working directly without issues.

I learnt that license manager uses TCP/IP Protocol and default port is 27004. This port has been opened on both the firewalls and verified with telnet command too.

After setting license manager pointing that machine and when I open a arcmap, am getting this error "“FLEXnet Licensing Error -15,10. System Error:10060: “WinSock: Connection Timed Out”

I tried with IP Address, Server name by adding in host file, set environmental variables with @. But nothing works. Pl see attached image.

License manager is running in that machine,since all ESRI applications working successfully. License file time period is valid, lgmrd is running.

Any clue will be highly appreicated. Is this ESRI Bug or so. Please help. This is very very urgent for me.

Regards
SR 
  Winsock Time out ESRI Forum.JPG (opens in new window)
 
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: “FLEXnet Licensing Error -15,10. System Error:10060: “WinSock: Connection Timed Out” 
Author Oren Gabay 
Date Nov 23, 2008 
Message The problem is that you only opened the port for LMGRD (27004). You also have to open the ARCGIS daemon port.

In order to do that first set constant PORT number for the VENDOR DAEMON. Do that by adding port number after the VENDOR line in the license file:

VENDOR ARCGIS port=xxxxx

After that open this port number on your firewall.

Also check this ESRI article: http://support.esri.com/index.cfm?fa=knowledgebase.techarticles.articleShow&d=26135

Oren Gabay
OpenLM
http://www.openlm.com