You are here: > ESRI Forums > arcgis desktop discussion forums > Thread Replies

ArcGIS Desktop Discussion Forums

ArcGIS Server: Server administration forum

Error: GIS server is not running on machine...   Lee Macholz Jan 19, 2006
Re: Error: GIS server is not running on mac...   LMVJV USFWS Jan 26, 2006
Re: Error: GIS server is not running on mac...   Lee Macholz Jan 26, 2006
Re: Error: GIS server is not running on mac...   LMVJV USFWS Jan 26, 2006
Re: Error: GIS server is not running on mac...   Lee Macholz Jan 26, 2006
SOLUTION: Error: GIS server is not running...   Jim Dillon Feb 02, 2006
Re: SOLUTION: Error: GIS server is not runn...   Elvia Cortes Feb 16, 2006
Re: Error: GIS server is not running on mac...   Lee Macholz Feb 16, 2006
Re: Error: GIS server is not running on mac...   Lee Macholz Feb 16, 2006
Re: Error: GIS server is not running on mac...   Steve Sharp Feb 23, 2006
Re: Error: GIS server is not running on mac...   Stephen Duckworth Mar 01, 2006
Re: Error: GIS server is not running on mac...   qsh zh Mar 02, 2006
Re: Error: GIS server is not running on mac...   qsh zh Mar 02, 2006
Re: Error: GIS server is not running on mac...   Jerry Garcia Mar 13, 2006
Re: Error: GIS server is not running on mac...   Allan Stewart Apr 04, 2006
Re: Error: GIS server is not running on mac...   Christopher Perry Apr 17, 2006
Re: Error: GIS server is not running on mac...   Ahad Kheirabadi Nov 05, 2006
Re: Error: GIS server is not running on mac...   Stavier K May 11, 2006
Re: Error: GIS server is not running on mac...   Hanna Sandoval May 24, 2006
Re: Error: GIS server is not running on mac...   Bill Sabo Jun 08, 2006
Re: Error: GIS server is not running on mac...   Guangming HE Jun 11, 2006
Re: Error: GIS server is not running on mac...   Dean Rother Jun 21, 2006
SOLUTION(possible): GIS server is not runni...   Matt Hartlove Sep 06, 2006
Re: SOLUTION(possible): GIS server is not r...   Valentina Boycheva Nov 16, 2006
Re: SOLUTION(possible): GIS server is not r...   Jim Nguyen Dec 11, 2006
Re: SOLUTION(possible): GIS server is not r...   Sonya Cowper Apr 08, 2008
Re: SOLUTION(possible): GIS server is not r...   Canada Mappers Canada Mappers Apr 17, 2008
Re: SOLUTION(possible): GIS server is not r...   vipul soni Apr 18, 2008
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Error: GIS server is not running on machine - but it is! 
Author Lee Macholz 
Date Jan 19, 2006 
Message In ArcCatalog, when I use the Add ArcGIS Server dialog to try to connect to our ArcGIS Server, I get an error that “GIS server is not running on machine [server name].” However, I can log onto the server and verify that GIS Server is indeed running.

I have one coworker that gets the same error as I do, and one coworker that can connect just fine. Our permissions are all set the same on the server and we are all members of agsadmin and agsuser. The ArcGIS Server installation is 9.0, I am running ArcGIS Desktop 9.1, my coworker that can connect to the server is running ArcGIS Desktop 9.0. Could the version difference be the problem? Any other ideas?

Thanks for the help!
-Lee 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author LMVJV USFWS 
Date Jan 26, 2006 
Message I've just run into this situation this AM. I was accessing my ArcGIS Server yesterday and now I'm getting the same error you posted. I'm trying to track what happened. Did you get your problem solved or have a good answer?

Thanks,
Johnny Rio 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Lee Macholz 
Date Jan 26, 2006 
Message No, I have not been able to figure it out yet. Let me know if you come up with something!

-Lee 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author LMVJV USFWS 
Date Jan 26, 2006 
Message My problem has something to do with logging on the network domain. When the PC is logged on locally (PC only) the connection to the ArcGIS Server is made just fine. When connected to the network domain, I received the message you described. The same is happening with Spatial database connections in ArcCatalog. Are your PCs logging in to a network domain? 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Lee Macholz 
Date Jan 26, 2006 
Message Yes, we are logging into a network domain. However, I have one coworker that can log on and get to the ArcGIS server no matter what we try. I can also get to the SDE databases we have on the same server just fine. We can also get to the ArcGIS Server in ArcCatalog when we log onto the computer with the agsSOM account.

We're stuck.
-Lee 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject SOLUTION: Error: GIS server is not running on machine - but it is! 
Author Jim Dillon 
Date Feb 02, 2006 
Message OK, I've just been through this same problem. ArcGIS Server running on Windows Server 2003, trying to connect over a network domain. With the ArcGIS Server SP AND the DCOM patch installed we still couldn't contact ArcGIS Server.

Try this: Go to the Computer Management app (explore, right-click on "My Computer", choose "Manage"), expand "Local Users and Groups", click on "Groups", add all domain users to the "Distributed COM Users" group. For my network, all domain users is "Domain Users", check with your Systems Admin for what it is on your network. Or if you only want specific individuals to have access then just add them individually to this group.

Hit apply and everything should work. No need to restart or logoff & login but you can if you're superstitious. Be sure you have the Server and Container objects (whatever you named them in the post-install) in the Users group. The Server object should also be in the agsadmin group. Neither of these need to be in the Distributed COM Users group.

Another workaround is to add users to the Administrators group. This is obviously a bad long-term solution, especially if you're running an internet application or have a wireless access point near your building. But it will at least allow you to develop if the above solution doesn't work for you.

Good luck!!

Jim 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: SOLUTION: Error: GIS server is not running on machine - but it is! 
Author Elvia Cortes 
Date Feb 16, 2006 
Message Hi,
I having the same problem. I have done everything that has been recommended, but I am still getting the same message that the GIS server is not running.
I even created local accounts in ArcGIS and ArcGIS server and then use those local credentials in ArcGIS but still no luck.
I am running Windows 2003 and ArcGIS Server 9.1. I have made sure the operating system accounts and domain user accounts have beeb added to the agsadmin and agsusers groups and even to the Distributed COM Users, but not success.

Please help

Thanks

Elvia Cortes 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Lee Macholz 
Date Feb 16, 2006 
Message Hello there, I still have not been able to connect to our ArcGIS Server. We have tried all combinations of user permissions that have been recommended. I was thinking that it was a version issue (we are running 9.0), but if you are having the same problem with 9.1 I am completely out of ideas.

Carla, Have you applied all the service packs to your 9.1 ArcGIS Server? I have heard that there is a patch that might address this issue in 9.1, but I don't know which one it is off the top of my head. 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Lee Macholz 
Date Feb 16, 2006 
Message Oops! Elvia, I called you by the wrong name, so sorry!! ...Don't know where I got Carla from!

-Lee 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Steve Sharp 
Date Feb 23, 2006 
Message Check this out

http://support.esri.com/index.cfm?fa=downloads.patchesServicePacks.viewPatch&PID=66&MetaID=1034

Sharpie 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Stephen Duckworth 
Date Mar 01, 2006 
Message I'm experiencing the same problem attempting to add ArcGIS Server which resides on a win2000 server.
The patch cited above applies to xp & 2003.

Anyone have ideas for win2000? 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author qsh zh 
Date Mar 02, 2006 
Message i have the same problem anyone got the solution? 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author qsh zh 
Date Mar 02, 2006 
Message few minites ago i got the solution 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Jerry Garcia 
Date Mar 13, 2006 
Message Can ESRI Tech Support contribute a trouble shooting list?

 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Allan Stewart 
Date Apr 04, 2006 
Message Any resolutions found!!!!

I am encountering the same issues: Windows 2003 SP1, ArcGIS Server 9.1 SP1, except the agsusers and agsadmin groups are not available to be added to the DCOM users.

Currently only I can access the server from any computer. All other co-workers are SOL. I have verified all the permissions and ran the updates.

Any suggestions????? 
  Allan Stewart
CALIBRE
Alexandria VA 22310
703.797.8500 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Christopher Perry 
Date Apr 17, 2006 
Message Did you re-run the post install routine after patching the server? Thats what had me stuck. 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Ahad Kheirabadi 
Date Nov 05, 2006 
Message Are you solve this problem ?

Can you share your soilution ???

Email: a_kheirabadi0@yahoo.com 
  Kheirabadi
KNTU-GIS
a_kheirabadi0@yahoo.com 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Stavier K 
Date May 11, 2006 
Message It is clearly given in documentation... attached with the CD.. The arcSOM, in which System it is installed, needs to be given.... to rectify the error and arc SOM needs to run on the MAchine or Server in which it is installed... which you can check by going to the sevices in Computer Management in Control PAnel... 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Hanna Sandoval 
Date May 24, 2006 
Message If you can connect to ArcGIS Server with ArcCatalog on the server itself and some colleagues can but from ArcCatalog on some client machines the connection fails, the issue may be due to your client machine not having DCOM enabled.

Try this: Go to Administrative Tools > Component Services > Computers > My Computer. Right click on My Computer and choose Properties.
On the Default Properties tab make sure that "Enable Distributed COM" is checked on.
I've seen this checked off on a few client machines running Windows XP SP2.

I hope that helps.
Hanna 
  ESRI Support Services 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Bill Sabo 
Date Jun 08, 2006 
Message Any more suggestions for this problem? I have tried pretty much everything suggested here, but still no success. 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Guangming HE 
Date Jun 11, 2006 
Message No sure which user is used to log on the arcgis server?

I can connect to arcgis server running on a win 2003 server through arccatelog on the server itself.

But could not on a win xp. my local network does not have a domain controller. if arccatelog uses the logged user on the win xp machine to try to access the arcgis server, i believe it can not because the server does not have any information about other machines.

Through codes, i can connect to the server programtically by using one user in arcgis user group.

my arcgis server is 9.1, and arc catelog is 9.0/.

I found in this configuration, you can not apply the patches from ESRI after post installations.

Guangming
 
  Share your ideas with me! 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Error: GIS server is not running on machine - but it is! 
Author Dean Rother 
Date Jun 21, 2006 
Message We too ran into this problem. We noticed an error in the event viewer that stated:

The application-specific permission settings do not grant Remote Activation permission for the COM Server application with CLSID

{379376DB-AEA6-40D1-9491-9345E61EF6BE}

to the user DOMAIN\User SID (...). This security permission can be modified using the Component Services administrative tool.


We followed the instructions at this link (http://support.microsoft.com/?kbid=899965) and resolved the issue.

The link doesn't work, search for the title "Event 10016 may be logged in the System log on a computer that is running Windows XP Professional x64 Edition" at http://support.microsoft.com.

Dean 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject SOLUTION(possible): GIS server is not running on machine - but it is! 
Author Matt Hartlove 
Date Sep 06, 2006 
Message I was having this problem for the past day, but I finally got it to work. I didn't see this in the suggestions here, so I'll share for anyone still having problems.

We don't have a domain here, so I have a local account on the server as well as the client machine. Once I changed my password on the server to match my client password, it worked fine. That might explain the issue where some people can log in and others can't, even though they have the same permissions. Have them sync their passwords, if they haven't already tried that.

Other windows server clients(SQL Server for example) will allow you to log in as another user, or with another password. Maybe that's something that should be considered in a new version.
 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: SOLUTION(possible): GIS server is not running on machine - but it is! 
Author Valentina Boycheva 
Date Nov 16, 2006 
Message For those of you who still have problems on XP SP2, make sure that the firewall settings on the GIS Server machine are propertly configured:

http://support.esri.com/index.cfm?fa=knowledgebase.techarticles.articleShow&d=27798
 
  Valentina Boycheva
Senior GIS Programmer/Analyst
http://www.jonesedmunds.com
 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: SOLUTION(possible): GIS server is not running on machine - but it is! 
Author Jim Nguyen 
Date Dec 11, 2006 
Message I tried everything in the thread but still cannot connect. I get the error message "gis server could not connect to..."

I tried the DCOM patch, the ArcGIS SP2 patch, ran the post install, and logged on and off. Did not work. I tried to synchonize the passwords but it did not work. I also opened holes in the windows firewall as suggested but still does not work.

I found this in the error log but am not sure if it is related.

Help please?

Server.cfg is not found.Configuration Engine.Engine is successfully added.Configuration SDM.ServerDirectoryManager is successfully added.Server is successfully started.Server failed to find place for a new instance. Machine list is empty.Server failed to find place for a new instance. Machine list is empty. 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: SOLUTION(possible): GIS server is not running on machine - but it is! 
Author Sonya Cowper 
Date Apr 08, 2008 
Message Jim,

Did you ever find a solution to your problem. I received that error as well and am at a lost on what to do next. If you could remember that would be great!

Thank you
Sonya 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: SOLUTION(possible): GIS server is not running on machine - but it is! 
Author Canada Mappers Canada Mappers 
Date Apr 17, 2008 
Message I'm having the event ID error 10016 myself. I have not yet found a solution, and I have tried the Microsoft fix mentioned.

 
 
Thanks,
Crayton 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: SOLUTION(possible): GIS server is not running on machine - but it is! 
Author vipul soni 
Date Apr 18, 2008 
Message sonya,

just elaborate your problem, which version of operating system with sp number ,arcgis server version number,and the lan network domain configured or not...and are u using arcgis desktop to connect to it then which version...

'
vipul soni 
  Vipul Soni

INDIA