You are here: > ESRI Forums > arcgis desktop discussion forums > Thread Replies

ArcGIS Desktop Discussion Forums

ArcGIS Desktop - Performance forum

Point shapefiles won't show up in map and t...   Amanda Bumgardner Apr 27, 2007
Re: Point shapefiles won't show up in map a...   Dan Patterson Apr 27, 2007
Re: Point shapefiles won't show up in map a...   David B Apr 27, 2007
Re: Point shapefiles won't show up in map a...   Amanda Bumgardner Apr 30, 2007
Re: Point shapefiles won't show up in map a...   Dan Patterson Apr 30, 2007
Re: Point shapefiles won't show up in map a...   David B Apr 30, 2007
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Point shapefiles won't show up in map and they don't have a red exclamation point. 
Author Amanda Bumgardner 
Date Apr 27, 2007 
Message I have been working on a culverts map where we put points where all the culverts are in my county. I found all the shapefiles of the culverts that we have so far and they used to be on the map. Well, recently when I open the map, 2 of the shapefiles have disappeared. They don’t have a red exclamation point next to them… they actually have a black check, so they should show up. I looked into ArcCatalog and previewed those shapefiles to see if anything was in them. The preview showed everything that we were missing. I have tried to add them by using the add button and by dragging them from ArcCatalog into the map again but nothing shows up. So I tried to open a new blank document to see if this map just froze or something. I could get all the line shapefiles on the map that I needed but I couldn't get any point shapefiles on the map. I tried adding other point shapefiles… they would show up in the table of contents and be checked but nothing would show on the map. I don’t quite understand and can’t really figure out what is wrong. Why won’t it let me add point shapefiles when I can add more than one line shapefiles fine? The way we get these point shapefiles is from downloading the GPS unit into GPS Pathfinder, which then converts them into a shapefile. Are we doing that process wrong or is there something wrong in the ArcMap itself? Well, if anyone could get back with me to help give some ideas of what could be wrong, I would appreciate it. Thanks!
 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Point shapefiles won't show up in map and they don't have a red exclamation point. 
Author Dan Patterson 
Date Apr 27, 2007 
Message the red ! means that the source file cannot be found, right-click on the layer, select Properties, then the Source tab and navigate to the folder containing the data and select it. Also, post a zipped shapefile if that doesn't work 
  Geomatics, Carleton University, Ottawa, Canada 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Point shapefiles won't show up in map and they don't have a red exclamation point. 
Author David B 
Date Apr 27, 2007 
Message Maybe they're showing up in the wrong place (due to lack of projection or incorrect projection)? Does the layer show if you add it by itself to a new empty map? If you right-click on one of the layers that doesn't show and choose Zoom to Layer does it show in some other location?
Another possibility is that the index file is missing or corrupted. 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Point shapefiles won't show up in map and they don't have a red exclamation point. 
Author Amanda Bumgardner 
Date Apr 30, 2007 
Message I did the zoom to layer and the points appeared but I could only see those. So I am assuming you are right that they are appearing in a different location due to the projection. How would I get that fixed? 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Point shapefiles won't show up in map and they don't have a red exclamation point. 
Author Dan Patterson 
Date Apr 30, 2007 
Message do the coordinates look like decimal degrees when added to an empty data frame, or are you using some projection? I would try to download them as decimal degrees and see if projection on the fly will put them in approximately the right area. Once, done, you can project them using arctoolbox 
  Geomatics, Carleton University, Ottawa, Canada 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Point shapefiles won't show up in map and they don't have a red exclamation point. 
Author David B 
Date Apr 30, 2007 
Message The best thing is if you can find information on what coordinate system the data actually uses, possibly from the data provider. Failing that you can follow the steps in this KB article to try to determine what the CS is: http://support.esri.com/index.cfm?fa=knowledgebase.techarticles.articleShow&d=24893

That article also refers to instructions on what to do once you have determined the CS of the data.

Hope that helps.