You are here: > ESRI Forums > arcgis explorer discussion forums > Thread Replies

ArcGIS Explorer Discussion Forums

ArcGIS Explorer: Installation forum

Can't uninstall earlier version in order to...   David Adler Oct 03, 2007
Re: Can't uninstall earlier version in orde...   chris whitmore Oct 03, 2007
Re: Can't uninstall earlier version in orde...   Bruce Sanderson Oct 12, 2007
Re: Can't uninstall earlier version in orde...   David Adler Oct 12, 2007
Re: Can't uninstall earlier version in orde...   chris whitmore Oct 12, 2007
Re: Can't uninstall earlier version in orde...   David Adler Oct 12, 2007
Re: Can't uninstall earlier version in orde...   chris whitmore Oct 16, 2007
Re: Can't uninstall earlier version in orde...   David Adler Oct 17, 2007
Uninstall ArcGIS Explorer in order to upgra...   Richard Daniels May 01, 2008
Re: Can't uninstall earlier version in orde...   John Sullivan Jun 13, 2008
Re: Can't uninstall earlier version in orde...   Juan G Jaime Aug 26, 2008
Re: Can't uninstall earlier version in orde...   chris whitmore Aug 26, 2008
Re: Can't uninstall earlier version in orde...   David Adler Aug 26, 2008
Re: Can't uninstall earlier version in orde...   John Sullivan Aug 26, 2008
Re: Can't uninstall earlier version in orde...   Juan G Jaime Aug 26, 2008
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Can't uninstall earlier version in order to upgrade 
Author David Adler 
Date Oct 03, 2007 
Message I'm trying to upgrade to 9.2.410 and get a message that version 9.2.380 is installed.

When it tries to uninstall, I get an error message "The installed product does not match the installation source(s). Until a matching source is provided or the installed product and source are synchronized, this action can not be performed"
It is looking for the source in:
e:\wintemp\ArcGISExplorer\

I get the same error trying to uninstall from the Windows Control Panel.

I no longer have (or can find) the previous ArcGIS Explorer install code. 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author chris whitmore 
Date Oct 03, 2007 
Message Create a log file of the uninstall and post it here. Use the command below to generate the log -

msiexec /X {7B18E7E2-AFCA-4CBE-8CD5-3613315AB262} /L*V C:\AGX_uninstall.log

Replace the drive path with whatever works for you, if necessary.

Thanks, 
  Chris Whitmore
ESRI Install Team 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author Bruce Sanderson 
Date Oct 12, 2007 
Message I am experiencing the same problem. Is there any solution yet?

Thanks,
 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author David Adler 
Date Oct 12, 2007 
Message I've attached the logfile. 
  AGX_UNINSTALL.LOG (opens in new window)
 
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author chris whitmore 
Date Oct 12, 2007 
Message This is happening because cached setup files in the C:\Windows\Installer were corrupted or removed. These files are placed there by the windows installer service so that when a product is uninstalled, the cached files are referenced to perform the uninstallation.

Have you run any utilities (disk drive clean ups, msizap, etc)that may have affected the contents in this folder?

Thanks, 
  Chris Whitmore
ESRI Install Team 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author David Adler 
Date Oct 12, 2007 
Message Yes, I did a disk cleanup which removed many files.

Is it possible to at least clean out the registry and then manually delete the program files? 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author chris whitmore 
Date Oct 16, 2007 
Message Follow these steps; they should get Build 410 on your machine and 380 removed.

From the Run box, input this command:

msiexec /I (your temp folder that contains the ArcGIS Explorer 410 download)\setup.msi REINSTALL=ALL REINSTALLMODE=vomus /qb

This will recache the windows installer files for you. After the reinstall completes, go to Add/Remove Programs and uninstall ArcGIS Explorer (it will complete successfully this time). Once the uninstall is complete, you can then launch a clean install of 410 (launch it from your temp folder or download it again).

Thanks, 
  Chris Whitmore
ESRI Install Team 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author David Adler 
Date Oct 17, 2007 
Message Thank you! That did it. 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Uninstall ArcGIS Explorer in order to upgrade 
Author Richard Daniels 
Date May 01, 2008 
Message Note that

msiexec /X {7B18E7E2-AFCA-4CBE-8CD5-3613315AB262}

at the command prompt in Windows (or Start | Run) will REMOVE build 9.2.450 also. Apparently ESRI did not updated the product code between these builds. 
  Richard Daniels 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author John Sullivan 
Date Jun 13, 2008 
Message I am running into a similar problem with my uninstall. I am trying to install a new version on my machine. The previous version could not find the executables when I arrived and was installed by a previous user. Attached is the log file from the uninstall. I would like to do a complete and clean uninstall so that I may install the new DVD cleanly.

Thanks for any help!
John 
  AGX_uninstall.log (opens in new window)
 
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author Juan G Jaime 
Date Aug 26, 2008 
Message John,
Have you found a fix for this yet? I am also having the same problem, but my build is a little older (ArcGIS Explorer 9.2 Build 350). There has to be a way to manually uninstall (deleting folders/registry keys)without having to go through the uninstaller. 
  AGX_uninstall.log (opens in new window)
 
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author chris whitmore 
Date Aug 26, 2008 
Message Hi Juan,

Have you run any utilities that perform clean up operations on your machine? Something that removes old files, registry keys, etc? According to your log file, the msi that is cached by the windows installer service at C:\Windows\Installer is missing (the windows installer service stores setup information in that folder for uninstalling products and applying patches).

Thanks, 
  Chris Whitmore
ESRI Install Team 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author David Adler 
Date Aug 26, 2008 
Message When all else fails, I've been pretty successful with the Windows Installer Cleanup although I haven't used this with ArcExplorer.
It is easy to find if you Google "Windows Installer Cleanup" 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author John Sullivan 
Date Aug 26, 2008 
Message Hi Juan,

Yes, I sure did. Someone suggested the "Windows Installer Cleanup" method and it worked great.

http://support.microsoft.com/kb/290301

I removed the installation through that utility and installed the new software. Good luck!

John 
   
Report Inappropriate Content • Top • Print • This Forum is closed for replies.    
Subject Re: Can't uninstall earlier version in order to upgrade 
Author Juan G Jaime 
Date Aug 26, 2008 
Message Thanks John! That did the trick! I'm now running the latest build (500).